Cerner users are experiencing degraded performance on iOS

Incident Report for Suki

Resolved

This incident has been fully resolved. We apologize for any inconvenience caused and appreciate your patience during this time.
Posted Feb 14, 2025 - 16:11 PST

Monitoring

The fix is published. We are closely monitoring the system for any recurrence. If you're experiencing any issues, please contact our support team.
Posted Feb 14, 2025 - 15:37 PST

Update

We are still waiting for approval in App Store.
Note: Cerner iOS users on version 2.5.1 are affected.
Posted Feb 14, 2025 - 14:02 PST

Update

We are still waiting for approval in App Store.
Posted Feb 14, 2025 - 13:01 PST

Update

We have submitted the iOS fix an hour ago and waiting for approval.
Posted Feb 14, 2025 - 10:11 PST

Identified

We've identified the cause and are working on a fix.
Posted Feb 14, 2025 - 08:59 PST

Investigating

We're investigating an issue affecting Cerner iOS users. We're working to identify the root cause and implement a fix as soon as possible.
Posted Feb 14, 2025 - 08:12 PST
This incident affected: iOS App.