We're pleased to announce that incident with intermittent issues when submitting partial dictation notes for Oracle Cerner & Epic has been fully resolved. We apologize for any inconvenience caused and appreciate your patience during this time.
Posted Jun 06, 2025 - 17:34 PDT
Monitoring
We've resolved the issue with submitting partial dictation notes and are closely monitoring the system for any recurrence. If you're experiencing any issues, please contact our support team.
Posted Jun 06, 2025 - 16:28 PDT
Identified
We've identified the cause of issue with submitting partial dictation notes and are working on a fix.
Posted Jun 06, 2025 - 13:54 PDT
Update
We are continuing to investigate intermittent issues when submitting partial dictation notes for Oracle Cerner & Epic. We apologize for any inconvenience caused and appreciate your patience during this time.
Posted Jun 06, 2025 - 12:32 PDT
Investigating
We're investigating an issue with submitting partial dictation notes. We're working to identify the root cause and implement a fix as soon as possible.
Posted Jun 06, 2025 - 09:05 PDT
This incident affected: Web App, iOS App, Android App, and Browser Extension.