Cerner patient lists loading issues

Incident Report for Suki

Resolved

Cerner patient lists loading issue has been fully resolved. We apologize for any inconvenience caused and appreciate your patience during this time.
Posted Aug 04, 2025 - 09:08 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 04, 2025 - 08:35 PDT

Investigating

We are aware of issues loading Cerner patient lists. We are actively working on resolving this issue and will let you know when we have an update.
Posted Aug 04, 2025 - 07:51 PDT
This incident affected: Web App, iOS App, Android App, and Browser Extension.