Issues connecting to Athena

Incident Report for Suki

Resolved

This incident has been fully resolved. We apologize for any inconvenience caused and appreciate your patience during this time.
Posted Dec 09, 2025 - 16:10 PST

Update

We are continuing to work on a fix for this issue.
Posted Dec 09, 2025 - 15:54 PST

Identified

We are currently experiencing issues connecting to Athena, which is causing issues within Suki. We are actively investigating this issue and will provide an update as soon as possible. We apologize for the inconvenience.
Posted Dec 09, 2025 - 15:49 PST
This incident affected: Web App, iOS App, Android App, and Browser Extension.