The incident has been fully resolved. We apologize for any inconvenience caused and appreciate your patience during this time.
Posted Jun 12, 2025 - 16:02 PDT
Monitoring
We've resolved issues caused by outage in Google Cloud Platform and are closely monitoring the system for any recurrence. If you're experiencing any issues, please contact our support team.
Posted Jun 12, 2025 - 15:04 PDT
Update
We're actively working to recover from impact by outage in Google Cloud Platform. We've made progress on partial restoration of Suki services.
Posted Jun 12, 2025 - 14:35 PDT
Identified
We've identified the cause of the outage and are currently working with Google to restore Suki functionality.
Posted Jun 12, 2025 - 12:56 PDT
Investigating
We're investigating an outage in Google Cloud Platform that is impacting Suki. We're working with Google to identify the root cause and implement a fix as soon as possible.
Posted Jun 12, 2025 - 11:45 PDT
This incident affected: Web App, iOS App, Android App, and Browser Extension.