Issues with loading schedules for Cerner users.

Incident Report for Suki

Resolved

This incident has been resolved. Monitoring is ongoing.
Posted Apr 28, 2025 - 09:07 PDT

Investigating

We are currently investigating this issue.
Posted Apr 28, 2025 - 07:30 PDT
This incident affected: Web App, iOS App, Android App, and Browser Extension.